El error z80, es uno de los errores más odiados por los propietarios de un sistema Neo Geo MVS.

Este tipo de error está directamente relacionado con la zona de la placa base encargada del audio y puede ser consecuencia de un fallo en alguno de los componentes que intervienen en la etapa de sonido: YM2610, NEO-D0, Ram 6116, IC-257 NEO, NEO-IC G0 ó el propio chip Z80.
(También puede deberse a que haya corrosión en alguna de las pistas de la placa.)

Cuando una base MVS tiene este error, esta deja de funcionar y al iniciarla aparece en la pantalla el texto: “Z80 ERROR”.
1 copia

Tenía por aquí una base MVS modelo MV1FZ con el temido error Z80 cojiendo polvo, asi que nada, he decidido que ya va siendo hora de repararla y de documentarlo todo para que sirva de guía a todo aquel que se encuentre con este problema.
Antes que nada he de decir que lamentablemente he perdido algunas de las imagenes que tomé de todo el proceso, como por ejemplo una imagen inicial de la base MVS antes de empezar con la reparación, pero bueno, he podido recrear las imagenes faltantes gracias a otra MVS y van a aportar mucho al documento.

¡Empezamos!

Cómo mi MV1FZ está sucísima, antes de nada, hay que darle una buena limpieza para ir descartando cosas…
2 copia

Detalle de los restos de polvo y suciedad acumulados en una la zona de la placa base.
3 copia

Tras limpiar la placa con un cepillo de cerdas blandas y alcohol, la base MVS luce asi de bien.

Según mis ultimas experiencias lo ideal para limpiar este tipo de pcb´s es una ducha de agua fría, un cepillo de cerdas blandas y KH7 (habiendo quitado previamente baterias en el caso que las hubiese, claro está).

Usar alcohol cómo elemento para la limpieza de pcb´s no es nada recomendable ya que puede deshacer el barníz de protección que llevan algunos pcb´s.
4 copia

Desmontamos por completo la base para limpiar bien todos los conectores.
5 copia

Una vez que hemos limpiado la base y comprobado que no hay corrosión las pistas, la volvemos a montar y probamos a ver si se solucionó el problema…
1 copia

Nada, mala suerte, seguimos teniendo el error Z80, llega el momento de probar con los integrados.

Primer problema con el que me encuentro, este modelo de base al ser más pequeña y compacta que la mayoría de los otros modelos, no tiene el chip Z80 estandar (DIP), lo tiene pero en un formato más pequeño (SMD), llamandose este chip 84C00AM-6. (Este mismo formato SMD del Z80 lo usan por ejemplo las Game Gear de Sega.)

Comparativa* de los microprocesadores Z80 en sus dos encapsulados:
L_Toshiba-TMPZ84C00AP-8DIP

T84C00AM-8SMD

*En la comparativa los dos microprocesadores no están la misma escala, por ello aclaro que el encapsulado DIP es muchísimo más grande que el SMD.

Y aquí donde se encuentra ubicado en la placa nuestro Z80.
6 copia

Dejandome llevar por la intuición y también porque en un alto porcentaje de los casos el culpable del error suele ser el integrado Z80, decido probar a sustituir en primer lugar este chip, asi que trás un poco de labor de búsqueda por la red, pido al pais del sol naciente el mencionado chip, que me tarda en llegar unas dos semanas.

Una vez con el chip nuevo en casa, llega la parte complicada, desoldar el viejo 84C00AM-6.
Para tal fin existen diversos métodos como pueden ser entre otros:
– Una estación desoldadora (que es el método más recomendable y que no tengo)
– Un ingenioso kit desoldador llamado Chipquik (que no tengo)
– El rudimentario método kamikaze-crucemos-los-dedos (que es el que tengo yo por aqui)

Este contundente último método consiste en con un cúter bien afilado y con muchiiiiiiisima paciencia y pulso, ir cortando las patillas del chip a la altura del encapsulado teniendo el cuidado de no dañar ninguna pista de la placa.

(Atención, no recomiendo usar este método sí no se ha hecho algo similar con anterioridad. Igualmente no me hago responsable de los posibles daños que puedan producirse en vuestras placas si no se realiza esta técnica de la manera adecuada.)
100_4900 copia

Con paciencia y buena letra se logran cortar todas las patillas del chip y ya sólo nos queda usar un poco de decapante e ir quitando con la ayuda de unas pinzas y el soldador una a una las patillas del viejo chip.
7 copia

Una vez que tenemos el área despejada, limpiamos bien la zona con malla desoldadora.
8 copia

y colocamos nuestro nuevo y flamante 84C00AM-6.
Armandonos de pulso y paciencia, vamos soldando todas las patillas a la placa.
100_4903 copia

9 copia

Ahora que tenemos cambiado el Z80, sólo queda una cosa, volver a montar la base…
10 copia

Ponerle cuaquier cartucho que tengamos a mano y cruzar los dedos…
100_4920 copia

Probamos y… Funcionaaaa!!!
100_4908 copia

¡A olvidarnos definitivamente del error z80 y a disfrutar de la MVS!
-Dalmore-

 

Texto revisado 21/3/15.

Anuncios

Comentarios en: "Reparación del error Z80 en base Neo Geo MVS" (3)

  1. Corrección sobre limpieza del pcb hecha el 21/3/15.

  2. donde comprates el componente a japon, lo pregungunto por que lo mismo mañana compro dos placas mvs una funcionando y la otra dice que tiene un error de color ram error, y dice que es de una u dos ram de la placa. gracias por adelantado

    • Hago muchas compras a tiendas online niponas y de otros paises, no recuerdo cúal fué con certeza, pero para que te hagas una idea, puedes encontrarlo por ejemplo en eBay.

Responder

Introduce tus datos o haz clic en un icono para iniciar sesión:

Logo de WordPress.com

Estás comentando usando tu cuenta de WordPress.com. Cerrar sesión / Cambiar )

Imagen de Twitter

Estás comentando usando tu cuenta de Twitter. Cerrar sesión / Cambiar )

Foto de Facebook

Estás comentando usando tu cuenta de Facebook. Cerrar sesión / Cambiar )

Google+ photo

Estás comentando usando tu cuenta de Google+. Cerrar sesión / Cambiar )

Conectando a %s

A %d blogueros les gusta esto: